about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Podgorny <pasis.ua@gmail.com>2012-10-24 01:50:16 +0300
committerDmitry Podgorny <pasis.ua@gmail.com>2012-10-24 01:50:16 +0300
commit7d6e64a53a40da1896ebaa17ffbbbe6cd2d02786 (patch)
treee9db0b14f61242c3e5afc14a678abd80c58dc3c2 /configure.ac
parentc2e94bfb20ad67a9f4986757a0672adf943e35f4 (diff)
downloadprofani-tty-7d6e64a53a40da1896ebaa17ffbbbe6cd2d02786.tar.gz
libraries order does matter when --as-needed is passed to linker
This fixes linking error when --as-needed option is used.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 9e4b18c6..bc376558 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,14 +16,22 @@ AC_ARG_WITH([libxml2],
     [AS_HELP_STRING([--with-libxml2], [link with libxml2 instead of expat])])
 
 # Checks for libraries.
-AC_CHECK_LIB([ncurses], [main], [], 
-    [AC_MSG_ERROR([ncurses is required for profanity])])
+if test "x$with_libxml2" = xyes; then
+    AC_CHECK_LIB([xml2], [main], [], 
+        [AC_MSG_ERROR([libxml2 is required for profanity])])
+else
+    AC_CHECK_LIB([expat], [main], [], 
+        [AC_MSG_ERROR([expat is required for profanity])])
+fi
+
 AC_CHECK_LIB([resolv], [main], [], 
     [AC_MSG_ERROR([libresolv is required for profanity])])
 AC_CHECK_LIB([ssl], [main], [], 
     [AC_MSG_ERROR([openssl is required for profanity])])
 AC_CHECK_LIB([strophe], [main], [], 
     [AC_MSG_ERROR([libstrophe is required for profanity])])
+AC_CHECK_LIB([ncurses], [main], [], 
+    [AC_MSG_ERROR([ncurses is required for profanity])])
 AC_CHECK_LIB([glib-2.0], [main], [], 
     [AC_MSG_ERROR([glib-2.0 is required for profanity])])
 AC_CHECK_LIB([curl], [main], [], 
@@ -33,14 +41,6 @@ AC_CHECK_LIB([notify], [main], [],
 AC_CHECK_LIB([headunit], [main], [], 
     [AC_MSG_NOTICE([headunit not found, will not be able to run tests])])
 
-if test "x$with_libxml2" = xyes; then
-    AC_CHECK_LIB([xml2], [main], [], 
-        [AC_MSG_ERROR([libxml2 is required for profanity])])
-else
-    AC_CHECK_LIB([expat], [main], [], 
-        [AC_MSG_ERROR([expat is required for profanity])])
-fi
-
 # Checks for header files.
 AC_CHECK_HEADERS([stdlib.h string.h])
 AC_CHECK_HEADERS([ncurses.h], [], [])