about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2020-06-04 12:29:49 +0200
committerMichael Vetter <jubalh@iodoru.org>2020-06-04 12:29:49 +0200
commit8c9aee22e81804bda6590ba80e9450ca90f56d14 (patch)
tree24b5949eafbcf5aa3052243256f77568f5dde308 /configure.ac
parent12cafe4e60532d9b82d9fa0bcce41a9b04cf8245 (diff)
downloadprofani-tty-8c9aee22e81804bda6590ba80e9450ca90f56d14.tar.gz
Correctly check for 'expect'
The expect library doesnt export 'main'. But it exports (and we use)
exp_expectl.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c8352645..69b76697 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,7 +337,7 @@ AM_CONDITIONAL([HAVE_STABBER], [false])
 AC_CHECK_LIB([stabber], [stbbr_start], [AM_CONDITIONAL([HAVE_STABBER], [true])],
     [AC_MSG_NOTICE([libstabber not found, will not be able to run functional tests])])
 AM_CONDITIONAL([HAVE_EXPECT], [false])
-AC_CHECK_LIB([expect], [main], [AM_CONDITIONAL([HAVE_EXPECT], [true])],
+AC_CHECK_LIB([expect], [exp_expectl], [AM_CONDITIONAL([HAVE_EXPECT], [true])],
     [AC_MSG_NOTICE([libexpect not found, will not be able to run functional tests])])
 
 ### Check for ncursesw/ncurses.h first, Arch linux uses ncurses.h for ncursesw