about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-01-28 22:40:01 +0000
committerJames Booth <boothj5@gmail.com>2014-01-28 22:40:01 +0000
commit96af960995a00b3c59cc9a4d82e8b1fff0c935fc (patch)
tree81e050a4e902e707280950ec8d6ff15f137b72f5 /configure.ac
parent5afb296e67785725e4462358fcc227e5f28b1a46 (diff)
downloadprofani-tty-96af960995a00b3c59cc9a4d82e8b1fff0c935fc.tar.gz
Disable OTR support by default until 4.0.0 is supported.
enable with: ./configure --enable-otr
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index acad1fb6..b457eed1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,8 +137,10 @@ if test "x$enable_otr" = xyes; then
 elif test "x$enable_otr" = xno; then
     AM_CONDITIONAL([BUILD_OTR], [false])
 elif test "x$enable_otr" = x; then
-    AC_CHECK_LIB([otr], [main], [],
-        [AM_CONDITIONAL([BUILD_OTR], [false]) AC_MSG_NOTICE([libotr not found, otr entryption support not enabled])])
+    AM_CONDITIONAL([BUILD_OTR], [false])
+### Add the following back in once libotr 4.0.0 support is enabled
+###    AC_CHECK_LIB([otr], [main], [],
+###        [AM_CONDITIONAL([BUILD_OTR], [false]) AC_MSG_NOTICE([libotr not found, otr entryption support not enabled])])
 fi
 
 ### cmocka is required only for tests, profanity shouldn't be linked with it