about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-05-02 00:59:40 +0100
committerJames Booth <boothj5@gmail.com>2014-05-02 00:59:40 +0100
commitaa0d4fe89287af2ca60ccd41d96171eedde1c4dd (patch)
tree6ff199aa574fb3895d1e004b31029d7cc9b5dae5 /configure.ac
parenta077d2008a25e5639f558c09077de5ebb8a921fd (diff)
parent8ecfbdff7d5a0ace68e1c6366de77ecf517c67d4 (diff)
downloadprofani-tty-aa0d4fe89287af2ca60ccd41d96171eedde1c4dd.tar.gz
Merge branch 'master' into otrsmp
Conflicts:
	install-all.sh
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 13f7699e..f94adcb7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,6 +122,9 @@ PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.26], [],
     [AC_MSG_ERROR([glib 2.26 or higher is required for profanity])])
 PKG_CHECK_MODULES([curl], [libcurl], [],
     [AC_MSG_ERROR([libcurl is required for profanity])])
+PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 2.8.0], [],
+    [AC_MSG_ERROR([gnutls is required for profanity])])
+
 AS_IF([test "x$PLATFORM" = xosx], [LIBS="$LIBS -lcurl"])
 
 ### Check for desktop notification support
@@ -216,9 +219,9 @@ AC_CHECK_HEADERS([ncurses.h], [], [])
 AM_CFLAGS="-Wall -Wno-deprecated-declarations"
 AS_IF([test "x$PACKAGE_STATUS" = xdevelopment],
     [AM_CFLAGS="$AM_CFLAGS -Wunused -Werror"])
-AM_CPPFLAGS="$AM_CPPFLAGS $glib_CFLAGS $curl_CFLAGS $libnotify_CFLAGS"
+AM_CPPFLAGS="$AM_CPPFLAGS $glib_CFLAGS $curl_CFLAGS $libnotify_CFLAGS $LIBGNUTLS_CFLAGS"
 AM_CPPFLAGS="$AM_CPPFLAGS -DTHEMES_PATH=\"\\\"$THEMES_PATH\\\"\""
-LIBS="$LIBS $glib_LIBS $curl_LIBS $libnotify_LIBS"
+LIBS="$LIBS $glib_LIBS $curl_LIBS $libnotify_LIBS $LIBGNUTLS_LIBS"
 
 AC_SUBST(AM_CFLAGS)
 AC_SUBST(AM_CPPFLAGS)