about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2016-07-14 00:00:46 +0100
committerJames Booth <boothj5@gmail.com>2016-07-14 00:00:46 +0100
commitace2715cf72e504c94794d096966d864810f6e23 (patch)
tree0d9452a10c584047c4d889d4412efee71ff48b63 /configure.ac
parent10814b044d0d3ab9b85afb64dfdb9abe6d2c1656 (diff)
downloadprofani-tty-ace2715cf72e504c94794d096966d864810f6e23.tar.gz
Added PYTHON3 define
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8d06ecfe..e6ee131e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,6 +96,7 @@ elif test "x$enable_python_plugins" = xyes; then
         fi
     fi
     AS_IF([test "x$PLATFORM" = xosx], [rm -f Python.framework])
+    AS_IF([test "x$PYTHON_VERSION" = x3], [AC_DEFINE([PYTHON3], [1], [Python 3 build])])
 else
     AM_CONDITIONAL([BUILD_PYTHON_API], [false])
 fi