about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorWilliam Wennerström <william@wstrm.dev>2020-02-14 12:50:52 +0100
committerWilliam Wennerström <william@wstrm.dev>2020-02-17 10:54:15 +0100
commitb267b065f5b4c6fef93cb6f26c59f2e5c7dc7342 (patch)
tree43e80dbd080fbaa38a50fe5501f4433ecb04925e /configure.ac
parentca3afa7e05ae87158b6c1bfca1758763d4b0d8a2 (diff)
downloadprofani-tty-b267b065f5b4c6fef93cb6f26c59f2e5c7dc7342.tar.gz
Add builds.sr.ht CI for OpenBSD
* Add .builds/openbsd.yml for builds.sr.ht
* Update travis-build.sh -> ci-build.sh with OpenBSD case
* Fix libdl check in configure.ac (OpenBSD has libdl built-in)
* Fix some minor issues found when compiling on OpenBSD with GCC (e.g.
  uninitialized variables)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 11 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 393e70d1..0800ea0a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,13 +106,17 @@ else
     if test "x$enable_plugins" = xno; then
         AM_CONDITIONAL([BUILD_C_API], [false])
     elif test "x$enable_c_plugins" != xno; then
-        AC_CHECK_LIB([dl], [main],
-            [AM_CONDITIONAL([BUILD_C_API], [true]) LIBS="$LIBS -ldl" AC_DEFINE([HAVE_C], [1], [C support])],
-            [AS_IF(
-                [test "x$enable_c_plugins" = xyes],
-                    [AC_MSG_ERROR([dl library needed to run C plugins])],
-                [AM_CONDITIONAL([BUILD_C_API], [false])])
-            ])
+        # libdl doesn't exist as a separate library in OpenBSD/FreeBSD and is
+        # provided in the standard libraries.
+        AS_IF([test "x$PLATFORM" = xopenbsd -o "x$PLATFORM" = xfreebsd],
+            [AM_CONDITIONAL([BUILD_C_API], [true]) AC_DEFINE([HAVE_C], [1], [C support])],
+            [AC_CHECK_LIB([dl], [main],
+                [AM_CONDITIONAL([BUILD_C_API], [true]) LIBS="$LIBS -ldl" AC_DEFINE([HAVE_C], [1], [C support])],
+                [AS_IF(
+                    [test "x$enable_c_plugins" = xyes],
+                        [AC_MSG_ERROR([dl library needed to run C plugins])],
+                    [AM_CONDITIONAL([BUILD_C_API], [false])])
+                ])])
     else
         AM_CONDITIONAL([BUILD_C_API], [false])
     fi