about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-03-06 20:45:35 +0000
committerJames Booth <boothj5@gmail.com>2014-03-06 20:45:35 +0000
commitc51cc954d84499f2b30e60289eba0fc435a0858d (patch)
treec9bdc799f860c5f9cc616b36f2d9fcc85e2c2c17 /configure.ac
parent89a35677bd084e11c6a647aac68c5fd2ae64e0bb (diff)
downloadprofani-tty-c51cc954d84499f2b30e60289eba0fc435a0858d.tar.gz
Moved platform check in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 12 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 3649bef4..8bf08ee3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,17 +2,6 @@
 # Process this file with autoconf to produce a configure script.
 
 AC_INIT([profanity], [0.4.0], [boothj5web@gmail.com])
-PACKAGE_STATUS="development"
-
-### Get git branch and revision if in development
-if test "x$PACKAGE_STATUS" = xdevelopment; then
-    AM_CONDITIONAL([INCLUDE_GIT_VERSION], [true])
-    AC_DEFINE([HAVE_GIT_VERSION], [1], [Include git info])
-else
-    AM_CONDITIONAL([INCLUDE_GIT_VERSION], [false])
-fi
-
-AC_DEFINE_UNQUOTED([PACKAGE_STATUS], ["$PACKAGE_STATUS"], [Status of this build])
 AC_CONFIG_SRCDIR([src/main.c])
 AC_CONFIG_HEADERS([src/config.h])
 AC_CONFIG_AUX_DIR([build-aux])
@@ -29,6 +18,18 @@ AS_CASE([$host_os],
     [cygwin], [PLATFORM="cygwin"],
     [PLATFORM="nix"])
 
+PACKAGE_STATUS="development"
+
+### Get git branch and revision if in development
+if test "x$PACKAGE_STATUS" = xdevelopment; then
+    AM_CONDITIONAL([INCLUDE_GIT_VERSION], [true])
+    AC_DEFINE([HAVE_GIT_VERSION], [1], [Include git info])
+else
+    AM_CONDITIONAL([INCLUDE_GIT_VERSION], [false])
+fi
+
+AC_DEFINE_UNQUOTED([PACKAGE_STATUS], ["$PACKAGE_STATUS"], [Status of this build])
+
 AS_IF([test "x$PLATFORM" = xcygwin],
     [AC_DEFINE([PLATFORM_CYGWIN], [1], [Cygwin])])