about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2015-07-20 23:28:23 +0100
committerJames Booth <boothj5@gmail.com>2015-07-20 23:28:23 +0100
commitc5a04de9fbc05acbd77219c2bbe1e315743a7ef2 (patch)
tree3acc1f7ba58c5209c639551ea03b32ef1381fe05 /configure.ac
parentd40998c4affcb76acea42b25455deb087f544dfc (diff)
downloadprofani-tty-c5a04de9fbc05acbd77219c2bbe1e315743a7ef2.tar.gz
Added libexpect check for functional tests
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ffb35a2b..f5e8764e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -243,7 +243,10 @@ PKG_CHECK_MODULES([cmocka], [cmocka], [],
 
 AM_CONDITIONAL([HAVE_STABBER], [false])
 AC_CHECK_LIB([stabber], [stbbr_start], [AM_CONDITIONAL([HAVE_STABBER], [true])],
-    [AC_MSG_NOTICE([stabber not found, will not be able to run functional tests])])
+    [AC_MSG_NOTICE([libstabber not found, will not be able to run functional tests])])
+AM_CONDITIONAL([HAVE_EXPECT], [false])
+AC_CHECK_LIB([expect], [main], [AM_CONDITIONAL([HAVE_EXPECT], [true])],
+    [AC_MSG_NOTICE([libexpect not found, will not be able to run functional tests])])
 
 ### Check for ncursesw/ncurses.h first, Arch linux uses ncurses.h for ncursesw
 AC_CHECK_HEADERS([ncursesw/ncurses.h], [], [])