about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2020-04-07 11:10:41 +0200
committerMichael Vetter <jubalh@iodoru.org>2020-04-07 11:10:41 +0200
commitd3a387a0ec6e5265f625de87318be2de610efb01 (patch)
treed33698386eded55c553da7658121d8d6679c98b9 /configure.ac
parent9aefbdcb5397540ec78d858006d76e2c1a0158f3 (diff)
downloadprofani-tty-d3a387a0ec6e5265f625de87318be2de610efb01.tar.gz
Downgrade dependencies
Use g_date_time_format() instead of g_date_time_format_iso8601() to only
rely on glib 2.56.0 which is the latest version in Debian Buster
(current stable).

We also only use basic sqlite functions so 3.27.0 should be fine there
(also the one in Debian buster).

Thanks to @DebXWoody.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0808e76e..67fb6638 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,8 +166,8 @@ AS_IF([test "x$ncurses_cv_wget_wch" != xyes],
     [AC_MSG_ERROR([ncurses does not support wide characters])])
 
 ### Check for glib libraries
-PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.62], [],
-    [AC_MSG_ERROR([glib 2.62 or higher is required for profanity])])
+PKG_CHECK_MODULES([glib], [glib-2.0 >= 2.56.0], [],
+    [AC_MSG_ERROR([glib 2.56.0 or higher is required for profanity])])
 PKG_CHECK_MODULES([gio], [gio-2.0], [],
     [AC_MSG_ERROR([libgio-2.0 from glib-2.0 is required for profanity])])
 
@@ -179,8 +179,8 @@ PKG_CHECK_MODULES([curl], [libcurl], [],
     [AC_CHECK_LIB([curl], [main], [],
         [AC_MSG_ERROR([libcurl is required for profanity])])])
 
-PKG_CHECK_MODULES([SQLITE], [sqlite3 >= 3.28.0], [],
-    [AC_MSG_ERROR([sqlite3 3.28.0 or higher is required for profanity profanity])])
+PKG_CHECK_MODULES([SQLITE], [sqlite3 >= 3.27.0], [],
+    [AC_MSG_ERROR([sqlite3 3.27.0 or higher is required for profanity profanity])])
 
 AS_IF([test "x$enable_icons_and_clipboard" != xno],
     [PKG_CHECK_MODULES([GTK], [gtk+-2.0 >= 2.24.10],