about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2013-09-17 00:59:37 +0100
committerJames Booth <boothj5@gmail.com>2013-09-17 00:59:37 +0100
commitd782b00711ddb3925738626e5509191932164975 (patch)
tree76c7381b9d749249fe55991504782e73ae556e4f /configure.ac
parente9361f834ae42e3218712d25f0d532dd1f1dc6b9 (diff)
downloadprofani-tty-d782b00711ddb3925738626e5509191932164975.tar.gz
Added git branch and revision to development builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a30c96d8..8468792c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,6 +4,15 @@
 AC_PREREQ([2.65])
 AC_INIT([profanity], [0.4.0], [boothj5web@gmail.com])
 PACKAGE_STATUS="development"
+
+## get git branch and revision if in development
+if test "x$PACKAGE_STATUS" = xdevelopment; then
+    AM_CONDITIONAL([INCLUDE_GIT_VERSION], [true])
+    AC_DEFINE_UNQUOTED([HAVE_GIT_VERSION], [1], [Include git info])
+else
+    AM_CONDITIONAL([INCLUDE_GIT_VERSION], [false])
+fi
+
 AC_DEFINE_UNQUOTED([PACKAGE_STATUS], ["$PACKAGE_STATUS"], [Status of this build])
 AC_CONFIG_SRCDIR([src/main.c])
 AC_CONFIG_HEADERS([src/config.h])