about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-09-07 23:54:31 +0100
committerJames Booth <boothj5@gmail.com>2014-09-07 23:54:31 +0100
commitf983438e97d92b639d053e0c188ea2fc0bed49fa (patch)
tree91f48f7d4eae1d5f21e6323ece3d5e1d81bca4a1 /configure.ac
parentb69c9aad8722c0fe1e115b15300743a36fc09305 (diff)
downloadprofani-tty-f983438e97d92b639d053e0c188ea2fc0bed49fa.tar.gz
Fixed check for wget_wch to not rely on header
As per pasis suggestion at #421
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index fab773a4..efc25770 100644
--- a/configure.ac
+++ b/configure.ac
@@ -103,9 +103,9 @@ CFLAGS_RESTORE="$CFLAGS"
 CFLAGS="$CFLAGS $NCURSES_CFLAGS"
 AC_CACHE_CHECK([for wget_wch support in $NCURSES], ncurses_cv_wget_wch,
    [AC_LINK_IFELSE([AC_LANG_SOURCE([
-       #include <ncurses.h>
+       void wget_wch(void);
        int main() {
-           (void)wget_wch(NULL, NULL);
+           wget_wch();
            return 0;
        }
        ])],