about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 23 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index b527351b..040e3f09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,27 +12,35 @@ AM_INIT_AUTOMAKE([foreign subdir-objects])
 AC_PROG_CC
 
 # Checks for libraries.
-AC_CHECK_LIB([ncurses], [main], [], [AC_MSG_ERROR([ncurses is required for profanity])])
-AC_CHECK_LIB([resolv], [main], [], [AC_MSG_ERROR([libresolv is required for profanity])])
-AC_CHECK_LIB([ssl], [main], [], [AC_MSG_ERROR([openssl is required for profanity])])
-AC_CHECK_LIB([expat], [main], [], [AC_MSG_ERROR([expat is required for profanity])])
-AC_CHECK_LIB([xml2], [main], [], [AC_MSG_ERROR([xml2 is required for profanity])])
-AC_CHECK_LIB([strophe], [main], [], [AC_MSG_ERROR([libstrophe is required for profanity])])
-AC_CHECK_LIB([glib-2.0], [main], [], [AC_MSG_ERROR([glib-2.0 is required for profanity])])
-AC_CHECK_LIB([notify], [main], [], [AC_MSG_NOTICE([libnotify not found])])
+AC_CHECK_LIB([ncurses], [main], [], 
+    [AC_MSG_ERROR([ncurses is required for profanity])])
+AC_CHECK_LIB([resolv], [main], [], 
+    [AC_MSG_ERROR([libresolv is required for profanity])])
+AC_CHECK_LIB([ssl], [main], [], 
+    [AC_MSG_ERROR([openssl is required for profanity])])
+AC_CHECK_LIB([expat], [main], [], 
+    [AC_MSG_ERROR([expat is required for profanity])])
+AC_CHECK_LIB([xml2], [main], [], 
+    [AC_MSG_ERROR([xml2 is required for profanity])])
+AC_CHECK_LIB([strophe], [main], [], 
+    [AC_MSG_ERROR([libstrophe is required for profanity])])
+AC_CHECK_LIB([glib-2.0], [main], [], 
+    [AC_MSG_ERROR([glib-2.0 is required for profanity])])
+AC_CHECK_LIB([notify], [main], [], 
+    [AC_MSG_NOTICE([libnotify not found])])
 
 # Checks for header files.
 AC_CHECK_HEADERS([stdlib.h string.h])
 
-PKG_CHECK_MODULES([OPENSSL], [openssl])
-PKG_CHECK_MODULES([NCURSES], [ncurses])
-PKG_CHECK_MODULES([GLIB], [glib-2.0])
-PKG_CHECK_MODULES([NOTIFY], [libnotify], [], [AC_MSG_NOTICE([libnotify module not found])])
+PKG_CHECK_MODULES([DEPS], [ncurses openssl glib-2.0])
+PKG_CHECK_MODULES([NOTIFY], [libnotify], [], 
+    [AC_MSG_NOTICE([libnotify module not found])])
 
-CFLAGS="$CFLAGS $GLIB_CFLAGS $GLIB_LIBS $NOTIFY_CFLAGS $NOTIFY_LIBS"
-CPPFLAGS="$CPPFLAGS $GLIB_CFLAGS $GLIB_LIBS $NOTIFY_CFLAGS $NOTIFY_LIBS"
+CFLAGS="$CFLAGS $DEPS_CFLAGS $DEPS_LIBS $NOTIFY_CFLAGS $NOTIFY_LIBS"
+CPPFLAGS="$CPPFLAGS $DEPS_CFLAGS $DEPS_LIBS $NOTIFY_CFLAGS $NOTIFY_LIBS"
 
-AC_CHECK_HEADERS([libnotify/notify.h], [], [AC_MSG_NOTICE([libnotify not found, desktop notification option not included])])
+AC_CHECK_HEADERS([libnotify/notify.h], [], 
+    [AC_MSG_NOTICE([libnotify not found, desktop notification option not included])])
 
 # Checks for typedefs, structures, and compiler characteristics.