about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b7774c13..f6ff55ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,6 +12,12 @@ AM_INIT_AUTOMAKE([foreign subdir-objects])
 # Checks for programs.
 AC_PROG_CC
 
+# get canonical host
+AC_CANONICAL_HOST
+if test "$host_os" == "cygwin"; then
+    AC_DEFINE([PLATFORM_CYGWIN], [1], [Cygwin])
+fi
+
 # Options
 AC_ARG_WITH([libxml2],
     [AS_HELP_STRING([--with-libxml2], [link with libxml2 instead of expat])])