about summary refs log tree commit diff stats
path: root/nix-conf/home/dev-common.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2022-10-22 14:37:23 +0100
committerDavid Morgan <djm_uk@protonmail.com>2022-10-22 14:37:23 +0100
commit2904502b4b9caac7938734b6c21bb71391743b82 (patch)
treec10e0cd8f2da89b02ef464c8ac2031c7c68a177f /nix-conf/home/dev-common.nix
parent2cff657838013a4e2843764f9b062e4fff2ad16d (diff)
downloaddotfiles-2904502b4b9caac7938734b6c21bb71391743b82.tar.gz
Tweak home-manager config
Diffstat (limited to 'nix-conf/home/dev-common.nix')
-rw-r--r--nix-conf/home/dev-common.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nix-conf/home/dev-common.nix b/nix-conf/home/dev-common.nix
new file mode 100644
index 0000000..da3665c
--- /dev/null
+++ b/nix-conf/home/dev-common.nix
@@ -0,0 +1,31 @@
+{ config, pkgs, ... }:
+{
+
+  imports = [
+    ./common.nix
+    ./clojure.nix
+  ];
+
+  home.packages = with pkgs; [
+    docker
+    docker-compose
+    gopass-jsonapi
+    mpv
+    mu
+    neovim
+  ];
+
+  programs.tmux = {
+    enable = true;
+    terminal = "screen-256color";
+    #tmuxp.enable = true;
+    extraConfig = ''
+      set-option -g status-bg '#666666'
+      set-option -g status-fg '#aaaaaa'
+      set-option -g status-left-length 50
+      set-option -g status-right " #(date ''\'+%a, %b %d - %I:%M''\') "
+    '';
+  };
+
+}
+