about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/clojure.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:26:06 +0000
committerDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:26:06 +0000
commit95bc01f27764cfdfc6229ffe3d59517dea0c9e5b (patch)
treee0bace9349f10118e79023ec1c39dba259623f9c /nix-conf/home/includes/clojure.nix
parentce9c53858fab4ef08ba3e683f6c29cd86a7be10d (diff)
downloaddotfiles-95bc01f27764cfdfc6229ffe3d59517dea0c9e5b.tar.gz
Reformat with newer nixfmt
Diffstat (limited to 'nix-conf/home/includes/clojure.nix')
-rw-r--r--nix-conf/home/includes/clojure.nix27
1 files changed, 21 insertions, 6 deletions
diff --git a/nix-conf/home/includes/clojure.nix b/nix-conf/home/includes/clojure.nix
index e362fd0..85bd261 100644
--- a/nix-conf/home/includes/clojure.nix
+++ b/nix-conf/home/includes/clojure.nix
@@ -1,8 +1,23 @@
-{ config, pkgs, lib, ... }:
-let inherit (lib) optionals;
-in {
-  home.packages = with pkgs;
-    [ babashka clj-kondo clojure clojure-lsp jet maven neil ]
+{
+  config,
+  pkgs,
+  lib,
+  ...
+}:
+let
+  inherit (lib) optionals;
+in
+{
+  home.packages =
+    with pkgs;
+    [
+      babashka
+      clj-kondo
+      clojure
+      clojure-lsp
+      jet
+      maven
+      neil
+    ]
     ++ optionals stdenv.isLinux [ leiningen ];
 }
-