about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/darwin.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2022-10-22 14:42:34 +0100
committerDavid Morgan <djm_uk@protonmail.com>2022-10-22 14:42:34 +0100
commitfa96356b1ece3788f13bf4b5729ac35036372069 (patch)
treecbe00bf3fb50da578c7a1bfa8837b9895775f187 /nix-conf/home/includes/darwin.nix
parent2904502b4b9caac7938734b6c21bb71391743b82 (diff)
downloaddotfiles-fa96356b1ece3788f13bf4b5729ac35036372069.tar.gz
Tweak home-manager config some more
Diffstat (limited to 'nix-conf/home/includes/darwin.nix')
-rw-r--r--nix-conf/home/includes/darwin.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/nix-conf/home/includes/darwin.nix b/nix-conf/home/includes/darwin.nix
new file mode 100644
index 0000000..d1b0d05
--- /dev/null
+++ b/nix-conf/home/includes/darwin.nix
@@ -0,0 +1,36 @@
+{ config, pkgs, ... }:
+{
+  imports = [
+    ./dev-common.nix
+  ];
+
+  home.packages = with pkgs; [
+    awscli2
+    coreutils
+    curl
+    diffutils
+    ((emacsPackagesFor emacsMacport).emacsWithPackages(ps: [ ps.vterm ]))
+    findutils
+    gh
+    #gnused
+    #adoptopenjdk-hotspot-bin-8
+    #lima
+    mpv
+    mu
+    nix # on darwin we are not using nixos (duh)
+    openvpn
+    pinentry_mac
+    pgcli
+    pgformatter
+    postgresql
+    #python310Packages.sqlparse
+    sqls
+    wget
+  ];
+
+  programs.java = {
+    enable = true;
+    #package = (pkgs.jdk8.overrideAttrs (_: { postPatch = "ln -nsf ../zulu-8.jdk/Contents/Home/man man"; }));
+  };
+}
+