about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/dev-common.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2022-11-09 20:54:27 +0000
committerDavid Morgan <djm_uk@protonmail.com>2022-11-09 20:56:07 +0000
commitb9c843c22c796fc218f86e54cef537c4a962661d (patch)
tree76240943f5f241b18214a59d17caa14f54de7a4c /nix-conf/home/includes/dev-common.nix
parentf208e67d997b848036a51a3ac45166a5576a83c4 (diff)
downloaddotfiles-b9c843c22c796fc218f86e54cef537c4a962661d.tar.gz
Improve tmux conf
Diffstat (limited to 'nix-conf/home/includes/dev-common.nix')
-rw-r--r--nix-conf/home/includes/dev-common.nix11
1 files changed, 9 insertions, 2 deletions
diff --git a/nix-conf/home/includes/dev-common.nix b/nix-conf/home/includes/dev-common.nix
index d569566..904b4f8 100644
--- a/nix-conf/home/includes/dev-common.nix
+++ b/nix-conf/home/includes/dev-common.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, pkgs, lib, ... }:
 {
 
   imports = [
@@ -19,12 +19,19 @@
     enable = true;
     terminal = "screen-256color";
     prefix = "C-x";
-    #tmuxp.enable = true;
     extraConfig = ''
+     tmux bind-key R run-shell ' \
+       tmux source-file ~/.config/tmux/tmux.conf > /dev/null; \
+       tmux display-message "Sourced .config/tmux/tmux.conf!"'
+      bind-key £ split-window -h
       set-option -g status-bg '#666666'
       set-option -g status-fg '#aaaaaa'
       set-option -g status-left-length 50
       set-option -g status-right " %a, %b %d - %H:%M "
+      ${lib.optionalString pkgs.stdenv.isLinux ''
+        bind-key -T copy-mode y send-keys -X copy-pipe-and-cancel "xsel -i -p && xsel -o -p | xsel -i -b"
+        bind-key C-y run "xsel -o | tmux load-buffer - ; tmux paste-buffer"
+      ''}
     '';
   };