about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/scripts/hm-changes-report.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:26:06 +0000
committerDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:26:06 +0000
commit95bc01f27764cfdfc6229ffe3d59517dea0c9e5b (patch)
treee0bace9349f10118e79023ec1c39dba259623f9c /nix-conf/home/includes/scripts/hm-changes-report.nix
parentce9c53858fab4ef08ba3e683f6c29cd86a7be10d (diff)
downloaddotfiles-95bc01f27764cfdfc6229ffe3d59517dea0c9e5b.tar.gz
Reformat with newer nixfmt
Diffstat (limited to 'nix-conf/home/includes/scripts/hm-changes-report.nix')
-rw-r--r--nix-conf/home/includes/scripts/hm-changes-report.nix7
1 files changed, 3 insertions, 4 deletions
diff --git a/nix-conf/home/includes/scripts/hm-changes-report.nix b/nix-conf/home/includes/scripts/hm-changes-report.nix
index 0df6e4c..65e7fe8 100644
--- a/nix-conf/home/includes/scripts/hm-changes-report.nix
+++ b/nix-conf/home/includes/scripts/hm-changes-report.nix
@@ -2,9 +2,9 @@
 
 # https://github.com/gvolpe/nix-config/blob/e28a220d0087064e6bad6b992b4914a65eb545e5/home/scripts/changes-report.nix
 let
-  hm-profiles =
-    "${config.home.homeDirectory}/.local/state/nix/profiles/home-manager-*-link";
-in pkgs.writeShellScriptBin "hm-changes-report" ''
+  hm-profiles = "${config.home.homeDirectory}/.local/state/nix/profiles/home-manager-*-link";
+in
+pkgs.writeShellScriptBin "hm-changes-report" ''
   # Disable nvd if there are less than 2 hm profiles.
   if [ $(ls -d1v ${hm-profiles} 2>/dev/null | wc -l) -lt 2 ]; then
     echo "Skipping changes report..."
@@ -12,4 +12,3 @@ in pkgs.writeShellScriptBin "hm-changes-report" ''
     ${pkgs.nvd}/bin/nvd diff $(ls -d1v ${hm-profiles} | tail -2)
   fi
 ''
-