about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/zsh.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2023-03-20 15:50:22 +0000
committerDavid Morgan <djm_uk@protonmail.com>2023-03-20 15:50:22 +0000
commit1e46e31b957711d73716a23387a06eff90de1cd5 (patch)
tree19e0d42774090d31c98eb99631a5db4fc96d0f15 /nix-conf/home/includes/zsh.nix
parent8fe4052f5a5988eb57d0b11da9984a55126fd93e (diff)
downloaddotfiles-1e46e31b957711d73716a23387a06eff90de1cd5.tar.gz
Add mkcd function from omz
Diffstat (limited to 'nix-conf/home/includes/zsh.nix')
-rw-r--r--nix-conf/home/includes/zsh.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/nix-conf/home/includes/zsh.nix b/nix-conf/home/includes/zsh.nix
index 1c758b2..f074194 100644
--- a/nix-conf/home/includes/zsh.nix
+++ b/nix-conf/home/includes/zsh.nix
@@ -185,6 +185,11 @@ in
         cd "$DIR"
       }
 
+      # From omz
+      function mkcd () {
+        mkdir -p $@ && cd ''${@:$#}
+      }
+
       tre () { command tre "$@" -e && source "/tmp/tre_aliases_$USER" 2>/dev/null; }
 
       function gcd () {