about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/zsh.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2024-06-06 09:42:53 +0100
committerDavid Morgan <djm_uk@protonmail.com>2024-06-06 09:42:53 +0100
commitb7de9753da85edb193b6dd9507bb4e0dc083ea1f (patch)
tree7650dc06d89c6533eb531bb6c52810f56cb3d2ae /nix-conf/home/includes/zsh.nix
parent6ed84ee67e246633dc280c66f4638a899b968dc5 (diff)
downloaddotfiles-b7de9753da85edb193b6dd9507bb4e0dc083ea1f.tar.gz
Add Emacs alias on Darwin
Diffstat (limited to 'nix-conf/home/includes/zsh.nix')
-rw-r--r--nix-conf/home/includes/zsh.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/nix-conf/home/includes/zsh.nix b/nix-conf/home/includes/zsh.nix
index 4858b62..9729386 100644
--- a/nix-conf/home/includes/zsh.nix
+++ b/nix-conf/home/includes/zsh.nix
@@ -1,6 +1,8 @@
 { config, pkgs, lib, isDarwin, ... }:
 let
-    inherit (lib) optionals;
+  inherit (lib)
+    optionalAttrs
+    optionals;
 in
 {
   home.packages = with pkgs; [
@@ -86,6 +88,9 @@ in
       glola = "git log --graph --pretty=\"%Cred%h%Creset -%C(auto)%d%Creset %s %Cgreen(%ar) %C(bold blue)<%an>%Creset\" --all";
       glog = "git log --oneline --decorate --graph";
       gloga = "git log --oneline --decorate --graph --all";
+    }
+    // optionalAttrs pkgs.stdenv.isDarwin {
+      oemacs = "open -a /Applications/Emacs.app";
     };
 
     localVariables = {