about summary refs log tree commit diff stats
path: root/nix-conf/machines/djmuk2/configuration.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:26:06 +0000
committerDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:26:06 +0000
commit95bc01f27764cfdfc6229ffe3d59517dea0c9e5b (patch)
treee0bace9349f10118e79023ec1c39dba259623f9c /nix-conf/machines/djmuk2/configuration.nix
parentce9c53858fab4ef08ba3e683f6c29cd86a7be10d (diff)
downloaddotfiles-95bc01f27764cfdfc6229ffe3d59517dea0c9e5b.tar.gz
Reformat with newer nixfmt
Diffstat (limited to 'nix-conf/machines/djmuk2/configuration.nix')
-rw-r--r--nix-conf/machines/djmuk2/configuration.nix26
1 files changed, 17 insertions, 9 deletions
diff --git a/nix-conf/machines/djmuk2/configuration.nix b/nix-conf/machines/djmuk2/configuration.nix
index f332103..9cc0a85 100644
--- a/nix-conf/machines/djmuk2/configuration.nix
+++ b/nix-conf/machines/djmuk2/configuration.nix
@@ -1,4 +1,5 @@
-{ config, pkgs, ... }: {
+{ config, pkgs, ... }:
+{
   imports = [ ./hardware-configuration.nix ];
 
   boot.tmp.cleanOnBoot = true;
@@ -46,7 +47,10 @@
     isNormalUser = true;
     home = "/home/djm";
     description = "David Morgan";
-    extraGroups = [ "wheel" "plocate" ];
+    extraGroups = [
+      "wheel"
+      "plocate"
+    ];
     shell = pkgs.zsh;
     openssh.authorizedKeys.keys = [
       "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCurCpxZCHtByB5wXzsjTXwMyDSB4+B8rq5XY6EGss58NwD8jc5cII4i+QUbCOGTiAggSZUSC9YIP24hjpOeNT/IYs5m7Qn1B9MtBAiUSrIYew8eDwnMLlPzN+k2x9zCrJeCHIvGJaFHPXTh1Lf5Jt2fPVGW9lksE/XUVOe6ht4N/b+nqqszXFhc8Ug6le2bC1YeTCVEf8pjlh/I7DkDBl6IB8uEXc3X2vxxbV0Z4vlBrFkkAywcD3j5VlS/QYfBr4BICNmq/sO3fMkbMbtAPwuFxeL4+h6426AARQZiSS0qVEc8OoFRBVx3GEH5fqVAWfB1geyLzei22HbjUcT9+xN davidmo@gendros"
@@ -59,11 +63,13 @@
   '';
   security.doas = {
     enable = true;
-    extraRules = [{
-      users = [ "djm" ];
-      noPass = true;
-      keepEnv = true;
-    }];
+    extraRules = [
+      {
+        users = [ "djm" ];
+        noPass = true;
+        keepEnv = true;
+      }
+    ];
   };
 
   programs.zsh.enable = true;
@@ -77,7 +83,10 @@
     wget
   ];
 
-  nix.settings.trusted-users = [ "root" "djm" ];
+  nix.settings.trusted-users = [
+    "root"
+    "djm"
+  ];
   nix.optimise.automatic = true;
   nix.optimise.dates = [ "03:00" ];
 
@@ -85,4 +94,3 @@
 
   system.stateVersion = "22.05";
 }
-
8 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290