about summary refs log tree commit diff stats
path: root/nix-conf/machines/edrahil/configuration.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:26:06 +0000
committerDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:26:06 +0000
commit95bc01f27764cfdfc6229ffe3d59517dea0c9e5b (patch)
treee0bace9349f10118e79023ec1c39dba259623f9c /nix-conf/machines/edrahil/configuration.nix
parentce9c53858fab4ef08ba3e683f6c29cd86a7be10d (diff)
downloaddotfiles-95bc01f27764cfdfc6229ffe3d59517dea0c9e5b.tar.gz
Reformat with newer nixfmt
Diffstat (limited to 'nix-conf/machines/edrahil/configuration.nix')
-rw-r--r--nix-conf/machines/edrahil/configuration.nix35
1 files changed, 25 insertions, 10 deletions
diff --git a/nix-conf/machines/edrahil/configuration.nix b/nix-conf/machines/edrahil/configuration.nix
index 76b294b..d78c2a8 100644
--- a/nix-conf/machines/edrahil/configuration.nix
+++ b/nix-conf/machines/edrahil/configuration.nix
@@ -1,5 +1,9 @@
-{ config, pkgs, ... }: {
-  imports = [ ./hardware-configuration.nix ./network-configuration.nix ];
+{ config, pkgs, ... }:
+{
+  imports = [
+    ./hardware-configuration.nix
+    ./network-configuration.nix
+  ];
 
   boot.tmp.cleanOnBoot = true;
   zramSwap.enable = true;
@@ -7,7 +11,10 @@
   networking.hostName = "edrahil";
   networking.firewall = {
     enable = true;
-    allowedTCPPorts = [ 113 2222 ];
+    allowedTCPPorts = [
+      113
+      2222
+    ];
   };
 
   services.openssh = {
@@ -43,7 +50,10 @@
     isNormalUser = true;
     home = "/home/djm";
     description = "David Morgan";
-    extraGroups = [ "wheel" "plocate" ];
+    extraGroups = [
+      "wheel"
+      "plocate"
+    ];
     shell = pkgs.zsh;
     openssh.authorizedKeys.keys = [
       "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCurCpxZCHtByB5wXzsjTXwMyDSB4+B8rq5XY6EGss58NwD8jc5cII4i+QUbCOGTiAggSZUSC9YIP24hjpOeNT/IYs5m7Qn1B9MtBAiUSrIYew8eDwnMLlPzN+k2x9zCrJeCHIvGJaFHPXTh1Lf5Jt2fPVGW9lksE/XUVOe6ht4N/b+nqqszXFhc8Ug6le2bC1YeTCVEf8pjlh/I7DkDBl6IB8uEXc3X2vxxbV0Z4vlBrFkkAywcD3j5VlS/QYfBr4BICNmq/sO3fMkbMbtAPwuFxeL4+h6426AARQZiSS0qVEc8OoFRBVx3GEH5fqVAWfB1geyLzei22HbjUcT9+xN davidmo@gendros"
@@ -56,11 +66,13 @@
   '';
   security.doas = {
     enable = true;
-    extraRules = [{
-      users = [ "djm" ];
-      noPass = true;
-      keepEnv = true;
-    }];
+    extraRules = [
+      {
+        users = [ "djm" ];
+        noPass = true;
+        keepEnv = true;
+      }
+    ];
   };
 
   programs.zsh.enable = true;
@@ -73,7 +85,10 @@
     wget
   ];
 
-  nix.settings.trusted-users = [ "root" "djm" ];
+  nix.settings.trusted-users = [
+    "root"
+    "djm"
+  ];
   nix.optimise.automatic = true;
   nix.optimise.dates = [ "03:00" ];