about summary refs log tree commit diff stats
path: root/nix-conf/machines/egalmoth/hardware-configuration.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:55:15 +0100
committerDavid Morgan <djm_uk@protonmail.com>2024-09-03 15:55:15 +0100
commit33141c2f7adb53c9de83390b45470d6665848450 (patch)
tree50143a54a53e5eb2fab8769239223f7fb003b9b8 /nix-conf/machines/egalmoth/hardware-configuration.nix
parentb21c0581c2a15da0f67b7b738c86f7e89ad1b3b9 (diff)
downloaddotfiles-33141c2f7adb53c9de83390b45470d6665848450.tar.gz
Format machine files with nixfmt
Diffstat (limited to 'nix-conf/machines/egalmoth/hardware-configuration.nix')
-rw-r--r--nix-conf/machines/egalmoth/hardware-configuration.nix26
1 files changed, 12 insertions, 14 deletions
diff --git a/nix-conf/machines/egalmoth/hardware-configuration.nix b/nix-conf/machines/egalmoth/hardware-configuration.nix
index 4a5ae74..4d15bf4 100644
--- a/nix-conf/machines/egalmoth/hardware-configuration.nix
+++ b/nix-conf/machines/egalmoth/hardware-configuration.nix
@@ -4,28 +4,26 @@
 { config, lib, pkgs, modulesPath, ... }:
 
 {
-  imports =
-    [ (modulesPath + "/installer/scan/not-detected.nix")
-    ];
+  imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
 
-  boot.initrd.availableKernelModules = [ "xhci_pci" "thunderbolt" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
+  boot.initrd.availableKernelModules =
+    [ "xhci_pci" "thunderbolt" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
   boot.initrd.kernelModules = [ ];
   boot.kernelModules = [ "kvm-intel" ];
   boot.extraModulePackages = [ ];
 
-  fileSystems."/" =
-    { device = "/dev/disk/by-uuid/b2189909-19fe-4f58-a8ff-4de288199843";
-      fsType = "ext4";
-    };
+  fileSystems."/" = {
+    device = "/dev/disk/by-uuid/b2189909-19fe-4f58-a8ff-4de288199843";
+    fsType = "ext4";
+  };
 
-  fileSystems."/boot" =
-    { device = "/dev/disk/by-uuid/6ED1-F330";
-      fsType = "vfat";
-    };
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-uuid/6ED1-F330";
+    fsType = "vfat";
+  };
 
   swapDevices =
-    [ { device = "/dev/disk/by-uuid/a130cacb-d7e0-4fb8-a312-a34d19f00796"; }
-    ];
+    [{ device = "/dev/disk/by-uuid/a130cacb-d7e0-4fb8-a312-a34d19f00796"; }];
 
   powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
 }