about summary refs log tree commit diff stats
path: root/nix-conf/machines/egalmoth/hardware-configuration.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2022-11-08 16:19:24 +0000
committerDavid Morgan <djm_uk@protonmail.com>2022-11-08 16:19:24 +0000
commitfe6cd64f9dde7f4876eaf941eb0cabb083e6375b (patch)
treeb6b9e2a5de7527d4bf488192483c69208828819a /nix-conf/machines/egalmoth/hardware-configuration.nix
parent2e0a1f333cd40aba24c0ee7869691f6814a3d781 (diff)
downloaddotfiles-fe6cd64f9dde7f4876eaf941eb0cabb083e6375b.tar.gz
Add config for some machines
Diffstat (limited to 'nix-conf/machines/egalmoth/hardware-configuration.nix')
-rw-r--r--nix-conf/machines/egalmoth/hardware-configuration.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nix-conf/machines/egalmoth/hardware-configuration.nix b/nix-conf/machines/egalmoth/hardware-configuration.nix
new file mode 100644
index 0000000..4a5ae74
--- /dev/null
+++ b/nix-conf/machines/egalmoth/hardware-configuration.nix
@@ -0,0 +1,31 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports =
+    [ (modulesPath + "/installer/scan/not-detected.nix")
+    ];
+
+  boot.initrd.availableKernelModules = [ "xhci_pci" "thunderbolt" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-intel" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    { device = "/dev/disk/by-uuid/b2189909-19fe-4f58-a8ff-4de288199843";
+      fsType = "ext4";
+    };
+
+  fileSystems."/boot" =
+    { device = "/dev/disk/by-uuid/6ED1-F330";
+      fsType = "vfat";
+    };
+
+  swapDevices =
+    [ { device = "/dev/disk/by-uuid/a130cacb-d7e0-4fb8-a312-a34d19f00796"; }
+    ];
+
+  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}