about summary refs log tree commit diff stats
path: root/nixconf/darwin.nix
diff options
context:
space:
mode:
authorDavid Morgan <djm_uk@protonmail.com>2022-09-10 15:51:06 +0100
committerDavid Morgan <djm_uk@protonmail.com>2022-09-10 15:51:06 +0100
commita43429841ae67b7bb73f87349888eb4645c5d92e (patch)
treed25e2bc24e0634b447c6d19bbd6e416fb776f9d9 /nixconf/darwin.nix
parentafbfbc667042538fa82b9a8162d4f3781cb35209 (diff)
downloaddotfiles-a43429841ae67b7bb73f87349888eb4645c5d92e.tar.gz
Add some nix home configuration
Diffstat (limited to 'nixconf/darwin.nix')
-rw-r--r--nixconf/darwin.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/nixconf/darwin.nix b/nixconf/darwin.nix
new file mode 100644
index 0000000..735b80d
--- /dev/null
+++ b/nixconf/darwin.nix
@@ -0,0 +1,36 @@
+{ config, pkgs, ... }:
+{
+  imports = [
+    ./clojure.nix
+  ];
+
+  home.packages = with pkgs; [
+    awscli2
+    coreutils
+    curl
+    diffutils
+    ((emacsPackagesFor emacsMacport).emacsWithPackages(ps: [ ps.vterm ]))
+    findutils
+    gh
+    #gnused
+    #adoptopenjdk-hotspot-bin-8
+    #lima
+    mpv
+    mu
+    nix # on darwin we are not using nixos (duh)
+    openvpn
+    pinentry_mac
+    pgcli
+    pgformatter
+    postgresql
+    #python310Packages.sqlparse
+    sqls
+    wget
+  ];
+
+  programs.java = {
+    enable = true;
+    #package = (pkgs.jdk8.overrideAttrs (_: { postPatch = "ln -nsf ../zulu-8.jdk/Contents/Home/man man"; }));
+  };
+}
+