about summary refs log tree commit diff stats
path: root/nix-conf/home/includes/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-conf/home/includes/common.nix')
-rw-r--r--nix-conf/home/includes/common.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nix-conf/home/includes/common.nix b/nix-conf/home/includes/common.nix
index 971aa7d..c9bd270 100644
--- a/nix-conf/home/includes/common.nix
+++ b/nix-conf/home/includes/common.nix
@@ -2,9 +2,9 @@
 let
   hcr = pkgs.callPackage ./scripts/hm-changes-report.nix { inherit config pkgs; };
   scr = pkgs.callPackage ./scripts/system-changes-report.nix { inherit config pkgs; };
+  email = builtins.readFile "${config.home.homeDirectory}/email.txt";
 in
 {
-
   imports = [
     ./zsh.nix
   ];
@@ -172,6 +172,7 @@ in
   programs.git = {
     enable = true;
     userName = "David Morgan";
+    userEmail = email;
     aliases = {
       # difftastic
       logt = "!sh -c 'GIT_EXTERNAL_DIFF=\"difft --background=dark\" git log -p --ext-diff'";