about summary refs log tree commit diff stats
path: root/nix-conf/machines/edrahil/network-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix-conf/machines/edrahil/network-configuration.nix')
-rw-r--r--nix-conf/machines/edrahil/network-configuration.nix21
1 files changed, 12 insertions, 9 deletions
diff --git a/nix-conf/machines/edrahil/network-configuration.nix b/nix-conf/machines/edrahil/network-configuration.nix
index 626232c..b8ce55f 100644
--- a/nix-conf/machines/edrahil/network-configuration.nix
+++ b/nix-conf/machines/edrahil/network-configuration.nix
@@ -1,13 +1,16 @@
-{ ... }: {
+{ ... }:
+{
   networking = {
-    interfaces.ens3.ipv6.addresses = [{
-      # Emulate nix-sops. Technically an anti-pattern, but IP addresses aren't real secrets, and this has to be embedded here,
-      # as we cannot set a file path to read it from.
-      # Populate/update with:
-      # SOPS_AGE_KEY=$(doas ssh-to-age -private-key -i /etc/ssh/ssh_host_ed25519_key) sops -d --extract '["ipv6_address"]' secrets/edrahil.yaml | doas tee /root/.config/secrets/ipv6_address
-      address = builtins.readFile "/root/.config/secrets/ipv6_address";
-      prefixLength = 64;
-    }];
+    interfaces.ens3.ipv6.addresses = [
+      {
+        # Emulate nix-sops. Technically an anti-pattern, but IP addresses aren't real secrets, and this has to be embedded here,
+        # as we cannot set a file path to read it from.
+        # Populate/update with:
+        # SOPS_AGE_KEY=$(doas ssh-to-age -private-key -i /etc/ssh/ssh_host_ed25519_key) sops -d --extract '["ipv6_address"]' secrets/edrahil.yaml | doas tee /root/.config/secrets/ipv6_address
+        address = builtins.readFile "/root/.config/secrets/ipv6_address";
+        prefixLength = 64;
+      }
+    ];
     defaultGateway6 = {
       address = "fe80::1";
       interface = "ens3";