about summary refs log tree commit diff stats
path: root/nixconf/egalmoth.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixconf/egalmoth.nix')
-rw-r--r--nixconf/egalmoth.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/nixconf/egalmoth.nix b/nixconf/egalmoth.nix
new file mode 100644
index 0000000..bbf090c
--- /dev/null
+++ b/nixconf/egalmoth.nix
@@ -0,0 +1,25 @@
+{ config, pkgs, ... }:
+{
+  imports = [ 
+    ./common.nix
+    ./linux-dev.nix
+  ];
+
+  # Let Home Manager install and manage itself.
+  programs.home-manager.enable = true;
+
+  # Home Manager needs a bit of information about you and the
+  # paths it should manage.
+  home.username = "djm";
+  home.homeDirectory = "/home/djm";
+  
+  # This value determines the Home Manager release that your
+  # configuration is compatible with. This helps avoid breakage
+  # when a new Home Manager release introduces backwards
+  # incompatible changes.
+  #
+  # You can update Home Manager without changing this value. See
+  # the Home Manager release notes for a list of state version
+  # changes in each release.
+  home.stateVersion = "21.11";
+}