about summary refs log tree commit diff stats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBen Morrison <ben@gbmor.dev>2020-05-26 19:03:58 -0400
committerBen Morrison <ben@gbmor.dev>2020-05-26 19:14:44 -0400
commita24e25977e713fbc5a06778ada4c21202209a598 (patch)
tree905db44444955494948fe2bcf1fee87aedb3d331 /Cargo.toml
parentffb92f1daa8b0e7258ada0186ddb683741cb4fd8 (diff)
downloadclinte-a24e25977e713fbc5a06778ada4c21202209a598.tar.gz
updated travis cfg; setup Cargo.toml for crates.io v0.4.4
Added pertinent fields to Cargo.toml to publish on crates.io and
lib.rs

Updated .travis.yml - using bionic for build, tarpaulin binary can
now be pulled rather than built in-place.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 11 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index ff581d0..9f1e812 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,10 +1,19 @@
 [package]
 name = "clinte"
-version = "0.4.3"
+version = "0.4.4"
 authors = ["Ben Morrison <ben@gbmor.dev>"]
 edition = "2018"
+description = "CLI note posting system for shared UNIX boxes."
+repository = "https://github.com/gbmor/clinte"
+readme = "README.md"
+keywords = ["social", "unix", "notes", "messages"]
+categories = ["command-line-utilities"]
+license = "ISC"
 
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[badges]
+travis-ci = { repository = "gbmor/clinte", branch = "master" }
+codecov = { repository = "gbmor/clinte", branch = "master", service = "github" }
+maintenance = { status = "stable" }
 
 [dependencies]
 chrono = "^0.4"