about summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>1997-08-07 20:52:46 -0400
committerThomas E. Dickey <dickey@invisible-island.net>1997-08-07 20:52:46 -0400
commit050803d49a91559644e86a4ed38f11ba0afffbe4 (patch)
treeb52ae4afdf50f9a127ddf76db2d182dbc12c3bd9 /configure.in
parent29e32111a2573cf7ecc9cd1d09dbf7dedd15dfcd (diff)
downloadlynx-snapshots-050803d49a91559644e86a4ed38f11ba0afffbe4.tar.gz
snapshot of project "lynx", label v2-7-1ac_0-48
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 90614c97..5991cfc7 100644
--- a/configure.in
+++ b/configure.in
@@ -148,7 +148,7 @@ sunos4*)
 	;;
 ultrix*)
 	# Increase the maximum size of functions that will be optimized.
-	test -z "$GCC" && CFLAGS="$CFLAGS -O -Olimit 600"
+	test -z "$GCC" && CFLAGS="$CFLAGS -O -Olimit 600 -G 7"
 	CFLAGS="$CFLAGS -DULTRIX" 
 	;;
 esac
@@ -313,9 +313,9 @@ AC_MSG_RESULT($cf_cv_dired)
 if test ".$cf_cv_dired" != ".no" ; then
 	AC_DEFINE(DIRED_SUPPORT)
 
-	AC_MSG_CHECKING(if you wish to extracting from archives via DirEd)
+	AC_MSG_CHECKING(if you wish to allow extracting from archives via DirEd)
 	CF_ARG_DISABLE(dired-archive,
-	[  --disable-dired-archive DirEd: disable dearchiving commands],,[AC_DEFINE(ARCHIVE_ONLY)])
+	[  --disable-dired-archive  DirEd: disable dearchiving commands],[AC_DEFINE(ARCHIVE_ONLY)])
 	AC_MSG_RESULT($enableval)
 
 	AC_MSG_CHECKING(if you wish to allow users to redefine DirEd keys)
@@ -396,11 +396,11 @@ CF_ARG_ENABLE(debug,
 	[with_debug=yes],
 	[with_debug=no])
 AC_MSG_RESULT($with_debug)
-if test "$with_debug" = "yes" ; then
-	AC_DEFINE(DEBUG)
-elif test -n "$GCC" ; then
+if test "$with_debug" != "yes" ; then
+if test -n "$GCC" ; then
 	CF_STRIP_G_OPT(CFLAGS)
 fi
+fi
 
 if test -n "$GCC"
 then