about summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>2007-07-31 20:57:23 -0400
committerThomas E. Dickey <dickey@invisible-island.net>2007-07-31 20:57:23 -0400
commit108f83ece979cf867a75faf321cd9d6dacc490b4 (patch)
treedd4970a2e7923be3fa49f5213507791087296bd2 /configure.in
parentf280565bc0561b7151fae26b4a3a9f07f9c923f5 (diff)
downloadlynx-snapshots-108f83ece979cf867a75faf321cd9d6dacc490b4.tar.gz
snapshot of project "lynx", label v2-8-7dev_5e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 12 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 58fa7cce..d730adb6 100644
--- a/configure.in
+++ b/configure.in
@@ -1,4 +1,4 @@
-dnl $LynxId: configure.in,v 1.157 2007/07/29 17:17:01 tom Exp $
+dnl $LynxId: configure.in,v 1.158 2007/07/30 22:12:37 tom Exp $
 dnl
 dnl Process this file with autoconf to produce a configure script.
 dnl
@@ -822,6 +822,9 @@ AC_MSG_RESULT($use_ja_utf8)
 if test $use_ja_utf8 != no ; then
 	AC_DEFINE(EXP_JAPANESEUTF8_SUPPORT)
 	AM_ICONV
+	if test "$USE_NLS" != yes ; then
+	  LIBS="$LIBICONV $LIBS"
+	fi
 fi
 
 use_dft_colors=no
@@ -989,15 +992,19 @@ if test $use_setfont = yes ; then
 	linux*)
 		CF_PATH_PROG(SETFONT, consolechars, setfont)
 		;;
+	os2*)
+		SETFONT=built-in
+		CF_VERBOSE(Assume $host_os has font-switching)
+		;;
 	*)
 		SETFONT=unknown
-		CF_VERBOSE(Assume $host_os has font-switching)
+		CF_VERBOSE(Assume $host_os has no font-switching)
 		;;
 	esac
-	if test -n "$SETFONT" ; then
-		AC_DEFINE(EXP_CHARTRANS_AUTOSWITCH)
-	else
+	if test -z "$SETFONT" ; then
 		AC_MSG_WARN(Cannot find a font-setting program)
+	elif test "$SETFONT" != unknown ; then
+		AC_DEFINE(EXP_CHARTRANS_AUTOSWITCH)
 	fi
 fi