about summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>1998-06-25 20:46:00 -0400
committerThomas E. Dickey <dickey@invisible-island.net>1998-06-25 20:46:00 -0400
commit5488a2e17cfeff78f8927f652ecb9750d7a28c29 (patch)
tree061d9ca743d7c0a2fed37bd1e22cb1f83dd7d051 /configure.in
parent159955668b23e32fb7cefa1638bb40b8b3a58fa9 (diff)
downloadlynx-snapshots-5488a2e17cfeff78f8927f652ecb9750d7a28c29.tar.gz
snapshot of project "lynx", label v2-8-1dev_17
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 19 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 575c6e3e..0f79a4f8 100644
--- a/configure.in
+++ b/configure.in
@@ -256,7 +256,9 @@ ultrix*)
 	# Increase the maximum size of functions that will be optimized.
 	test -z "$GCC" && TRY_CFLAGS="$TRY_CFLAGS -O -Olimit 600 -G 7"
 	CFLAGS="$CFLAGS -DULTRIX" 
-	AC_CHECK_HEADERS(cursesX.h, cf_cv_ncurses_header=cursesX.h)
+	AC_CHECK_HEADERS(cursesX.h,
+		[AC_DEFINE(HAVE_CURSESX_H)
+		 cf_cv_ncurses_header=cursesX.h])
 	;;
 esac
 AC_SUBST(PROG_EXT)
@@ -275,7 +277,22 @@ dnl --------------------------------------------------------------------------
 dnl Checks for library configuration (added right-to-left)
 dnl --------------------------------------------------------------------------
 
-CF_NETLIBS
+### Look for network libraries first, since some functions (such as gethostname)
+### are used in a lot of places.
+AC_MSG_CHECKING(if you want socks5 library)
+AC_CACHE_VAL(cf_cv_use_libsocks5,[
+AC_ARG_WITH(socks5,
+	[  --with-socks5           link with socks5 if available],
+	[cf_cv_use_libsocks5=yes],
+	[cf_cv_use_libsocks5=no])
+])
+AC_MSG_RESULT($cf_cv_use_libsocks5)
+
+if test $cf_cv_use_libsocks5 = yes ; then
+	CF_SOCKS5
+else
+	CF_NETLIBS
+fi
 
 AC_MSG_CHECKING(for screen type)
 dnl This has to be cached, since there's a lot of interdependent tests.