about summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>1998-02-19 10:57:28 -0500
committerThomas E. Dickey <dickey@invisible-island.net>1998-02-19 10:57:28 -0500
commit899516a7c8880df05e30bbbed72ca1d3cb7a4f00 (patch)
tree14b895432dc4e84686c36bdeee4c689706af5361 /configure.in
parentc82d2a4041724afe1dce249c78c4f034ca6a8d69 (diff)
downloadlynx-snapshots-899516a7c8880df05e30bbbed72ca1d3cb7a4f00.tar.gz
snapshot of project "lynx", label v2-7-1ac-0_115
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ccfe31d4..4da43109 100644
--- a/configure.in
+++ b/configure.in
@@ -320,6 +320,7 @@ dnl Checks for library units
 dnl --------------------------------------------------------------------------
 
 AC_FUNC_VFORK
+CF_FIONBIO
 CF_REMOVE_BROKEN
 AC_CHECK_FUNCS( \
 	cuserid \
@@ -410,6 +411,14 @@ no)
 esac
 AC_SUBST(INSTALL_LSS)
 
+AC_MSG_CHECKING(if you want to use extended HTML DTD logic)
+CF_ARG_DISABLE(extended-dtd,
+[  --disable-extended-dtd  disable extended HTML DTD logic],
+	[use_ext_htmldtd=no],
+	[use_ext_htmldtd=yes])
+AC_MSG_RESULT($use_ext_htmldtd)
+test $use_ext_htmldtd = "no" && AC_DEFINE(NO_EXTENDED_HTMLDTD)
+
 AC_MSG_CHECKING(if you want to use external commands)
 CF_ARG_ENABLE(externs,
 [  --enable-externs        use external commands],