about summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>1999-04-23 15:06:34 -0400
committerThomas E. Dickey <dickey@invisible-island.net>1999-04-23 15:06:34 -0400
commita735f5ad5123baaa15a0057515f3b242c5d3f372 (patch)
tree58936995ce9e2afd4ba65a735fd44c15509db19a /configure.in
parentb223937ff728f8242329bedb9c660e81da253e9a (diff)
downloadlynx-snapshots-a735f5ad5123baaa15a0057515f3b242c5d3f372.tar.gz
snapshot of project "lynx", label v2-8-2dev_23
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 13 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 0a01f9a2..96b86b37 100644
--- a/configure.in
+++ b/configure.in
@@ -9,11 +9,12 @@ rm -f config.cache
 AC_INIT(userdefs.h)
 AC_CONFIG_HEADER(lynx_cfg.h:config.hin)
 
+CF_CHECK_CACHE
+
 dnl Set of available languages (wishful thinking :-).
 ALL_LINGUAS="de es fr it ko nl no pl pt sl sv"
 
 AC_PREFIX_DEFAULT(/usr/local)
-AC_CANONICAL_HOST
 
 dnl --------------------------------------------------------------------------
 dnl Checks for location of programs
@@ -582,7 +583,6 @@ if test $use_color_style != no ; then
 		AC_ERROR(Configuration does not support color-styles)
 	fi
 	AC_DEFINE(USE_HASH)
-	AC_DEFINE(USE_PSRC)
 	AC_DEFINE(LINKEDSTYLES)
 fi
 
@@ -642,6 +642,14 @@ CF_ARG_ENABLE(persistent-cookies,
 AC_MSG_RESULT($use_filed_cookies)
 test $use_filed_cookies != no && AC_DEFINE(EXP_PERSISTENT_COOKIES)
 
+AC_MSG_CHECKING(if html source should be colorized)
+CF_ARG_ENABLE(prettysrc,
+[  --enable-prettysrc      colorize HTML source],
+	[use_prettysrc=$enableval],
+	[use_prettysrc=no])
+AC_MSG_RESULT($use_prettysrc)
+test $use_prettysrc != no && AC_DEFINE(USE_PSRC)
+
 AC_MSG_CHECKING(if source caching should be used)
 CF_ARG_ENABLE(source-cache,
 [  --enable-source-cache   cache HTML source for parse mode changes],
@@ -813,7 +821,7 @@ Directory Editor Options:)
 # or modified at run time via DIRED_MENU symbols in lynx.cfg.
 AC_MSG_CHECKING(if directory-editor code should be used)
 CF_ARG_DISABLE(dired,
-[  --disable-dired          enable optional directory-editor, DirEd],
+[  --disable-dired          disable optional directory-editor, DirEd],
 	[use_dired=$enableval],
 	[use_dired=yes])
 AC_MSG_RESULT($use_dired)
@@ -886,7 +894,7 @@ srcdir="$srcdir"
 SRCDIR_CLEAN="#"
 if test -n "$srcdir" ; then
 	echo srcdir is $srcdir
-	$srcdir/mkdirs.sh WWW/Library/unix
+	$srcdir/mkdirs.sh WWW/Library/Implementation
 	$srcdir/mkdirs.sh src/chrtrans
 	test "$USE_INCLUDED_LIBINTL" = yes && $srcdir/mkdirs.sh intl
 	test "$srcdir" != "." && SRCDIR_CLEAN=""
@@ -898,7 +906,7 @@ AC_SUBST(CONFIG_SHELL)
 AC_SUBST(SRCDIR_CLEAN)
 AC_OUTPUT(
 	[makefile \
-	WWW/Library/unix/makefile \
+	WWW/Library/Implementation/makefile \
 	src/makefile \
 	src/chrtrans/makefile \
 	$SUB_MAKEFILE