about summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>1997-12-18 17:31:01 -0500
committerThomas E. Dickey <dickey@invisible-island.net>1997-12-18 17:31:01 -0500
commitb6c832d07f5a1c68607a9cff0da25cee0de89dad (patch)
tree46428c4ecb61ce53eccb5b9c367a917e9e6dba9d /configure.in
parent97d3287af85e3890f03d2a48474de0d1a431b676 (diff)
downloadlynx-snapshots-b6c832d07f5a1c68607a9cff0da25cee0de89dad.tar.gz
snapshot of project "lynx", label v2-7-1ac_0-102
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index d56702c7..d0962e02 100644
--- a/configure.in
+++ b/configure.in
@@ -47,7 +47,7 @@ CF_ARG_ENABLE(debug,
 AC_MSG_RESULT($with_debug)
 if test "$with_debug" = "yes" ; then
 	case $host_os in
-	ultrix*|osf[34].*)
+	ultrix*|osf*)
 		CF_STRIP_O_OPT(CFLAGS)
 		if test -z "$GCC" ; then
 			CFLAGS="$CFLAGS -g3"
@@ -56,7 +56,7 @@ if test "$with_debug" = "yes" ; then
 	esac
 else
 	case $host_os in
-	ultrix*) #(vi
+	ultrix*|osf*) #(vi
 		CF_STRIP_G_OPT(CFLAGS)
 		;;
 	*)
@@ -265,7 +265,6 @@ ncurses)
 	CF_NCURSES_LIBS
 	;;
 slang)
-	CF_TERMCAP_LIBS
 	CF_SLANG_CPPFLAGS
 	CF_SLANG_LIBS
 	;;
@@ -318,6 +317,7 @@ AC_CHECK_FUNCS( \
 	getgroups \
 	putenv \
 	readdir \
+	strerror \
 	waitpid \
 )
 AC_REPLACE_FUNCS( \
@@ -351,6 +351,8 @@ if test $cf_cv_screen != slang ; then
 	AC_CHECK_FUNCS( \
 		cbreak \
 		keypad \
+		use_default_colors \
+		wborder \
 	)
 fi
 
@@ -410,6 +412,14 @@ no)
 	;;
 esac
 
+AC_MSG_CHECKING(if you want to use external commands)
+CF_ARG_ENABLE(externs,
+[  --enable-externs        use external commands],
+	[use_externs=yes],
+	[use_externs=no])
+AC_MSG_RESULT($use_externs)
+test $use_externs != ".no" && AC_DEFINE(USE_EXTERNS)
+
 AC_MSG_CHECKING(if you want to use zlib for decompression of some gzip files)
 AC_ARG_WITH(zlib,
 [  --with-zlib             use zlib for decompression of some gzip files],