about summary refs log tree commit diff stats
path: root/configure.in
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>1998-07-31 09:38:29 -0400
committerThomas E. Dickey <dickey@invisible-island.net>1998-07-31 09:38:29 -0400
commite6ba2a01f70f84d9133cf305e4b493c9d656cb21 (patch)
tree264c4d01cf7791c9f77d583f05456a6108df3cdc /configure.in
parentaa3258c631eaca9dc2e7e2590b8778b827006144 (diff)
downloadlynx-snapshots-e6ba2a01f70f84d9133cf305e4b493c9d656cb21.tar.gz
snapshot of project "lynx", label v2-8-1dev_19
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 27 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index dede0b18..eb1c7b77 100644
--- a/configure.in
+++ b/configure.in
@@ -24,6 +24,9 @@ CF_MAKE_INCLUDE
 AC_PROG_INSTALL
 AC_CHECK_PROGS(LINT, lint alint lclint tdlint, [])
 
+AC_AIX
+AC_ISC_POSIX
+
 dnl --------------------------------------------------------------------------
 dnl Debug/development/test
 dnl --------------------------------------------------------------------------
@@ -279,24 +282,30 @@ dnl --------------------------------------------------------------------------
 
 ### Look for network libraries first, since some functions (such as gethostname)
 ### are used in a lot of places.
-AC_MSG_CHECKING(if you want socks5 library)
-AC_CACHE_VAL(cf_cv_use_libsocks5,[
+AC_CACHE_CHECK(if you want socks library,cf_cv_use_libsocks,[
+AC_ARG_WITH(socks,
+	[  --with-socks[=path]     link with socks library if available],
+	[cf_cv_use_libsocks=$withval],
+	[cf_cv_use_libsocks=no])
+])
+
+AC_CACHE_CHECK(if you want socks5 library,cf_cv_use_libsocks5,[
 AC_ARG_WITH(socks5,
-	[  --with-socks5           link with socks5 if available],
-	[cf_cv_use_libsocks5=yes],
+	[  --with-socks5[=path]    link with socks5 library if available],
+	[cf_cv_use_libsocks5=$withval],
 	[cf_cv_use_libsocks5=no])
 ])
-AC_MSG_RESULT($cf_cv_use_libsocks5)
 
-if test $cf_cv_use_libsocks5 = yes ; then
-	CF_SOCKS5
+if test "x$cf_cv_use_libsocks" != xno ; then
+	CF_SOCKS($cf_cv_use_libsocks)
+elif test "x$cf_cv_use_libsocks5" != xno ; then
+	CF_SOCKS5($cf_cv_use_libsocks5)
 else
 	CF_NETLIBS
 fi
 
-AC_MSG_CHECKING(for screen type)
 dnl This has to be cached, since there's a lot of interdependent tests.
-AC_CACHE_VAL(cf_cv_screen,[
+AC_CACHE_CHECK(for screen type, cf_cv_screen,[
 AC_ARG_WITH(screen,
 [  --with-screen=XXX       select screen type
                           (XXX is curses (default), ncurses or slang)],
@@ -309,7 +318,6 @@ curses|ncurses|slang)
 	;;
 esac],
 	[cf_cv_screen=curses])])
-AC_MSG_RESULT($cf_cv_screen)
 
 if test $cf_cv_screen != ncurses ; then
 	if eval "test \"`echo '$''{'cf_cv_ncurses_header'+set}'`\" != set"; then
@@ -366,6 +374,7 @@ AC_CHECK_HEADERS( \
 )
 CF_TERMIO_AND_TERMIOS
 CF_FUNC_WAIT
+AC_TYPE_GETGROUPS
 AC_TYPE_PID_T
 AC_TYPE_UID_T
 AC_TYPE_MODE_T
@@ -403,7 +412,6 @@ dnl --------------------------------------------------------------------------
 
 CF_BOOL_DEFS
 CF_ERRNO
-CF_GETGROUPS
 CF_LOCALE
 CF_NGROUPS
 CF_SYS_ERRLIST
@@ -441,6 +449,14 @@ CF_ARG_ENABLE(8bit-toupper,
 AC_MSG_RESULT($use_8bit_toupper)
 test $use_8bit_toupper != no && AC_DEFINE(EXP_8BIT_TOUPPER)
 
+AC_MSG_CHECKING(if experimental forms-based options screen should be used)
+CF_ARG_ENABLE(forms-options,
+[  --enable-forms-options  use experimental forms-based options],
+	[use_forms_options=$enableval],
+	[use_forms_options=no])
+AC_MSG_RESULT($use_forms_options)
+test $use_forms_options != no && AC_DEFINE(EXP_FORMS_OPTIONS)
+
 AC_MSG_CHECKING(if experimental persistent-cookie logic should be used)
 CF_ARG_ENABLE(persistent-cookies,
 [  --enable-persistent-cookies   use experimental persistent-cookie support],