about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2022-06-29 09:41:40 +0200
committerGitHub <noreply@github.com>2022-06-29 09:41:40 +0200
commit412a0a573714c11188cd4a59d871509f8eebbf86 (patch)
tree461b82fda0388c5ca1da5348118eb0995724a668 /Makefile.am
parent5fabca1e3746634eed2be3244313af173c1b6a7d (diff)
parentca9cc3275a6bf0225540d6f0d497504fd024253d (diff)
downloadprofani-tty-412a0a573714c11188cd4a59d871509f8eebbf86.tar.gz
Merge pull request #1728 from profanity-im/cleanup-pgp-ox
Split pgp and ox into separate files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c1d88c1..2a906a8e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,6 +84,7 @@ unittest_sources = \
 	src/ui/ui.h \
 	src/otr/otr.h \
 	src/pgp/gpg.h \
+	src/pgp/ox.h \
 	src/omemo/omemo.h \
 	src/omemo/crypto.h \
 	src/omemo/store.h \
@@ -188,10 +189,12 @@ c_sources = \
 git_include = src/gitversion.h
 
 pgp_sources = \
-	src/pgp/gpg.h src/pgp/gpg.c
+	src/pgp/gpg.h src/pgp/gpg.c \
+	src/pgp/ox.h src/pgp/ox.c
 
 pgp_unittest_sources = \
-	tests/unittests/pgp/stub_gpg.c
+	tests/unittests/pgp/stub_gpg.c \
+	tests/unittests/pgp/stub_ox.c
 
 otr4_sources = \
 	src/otr/otrlib.h src/otr/otrlibv4.c src/otr/otr.h src/otr/otr.c