about summary refs log tree commit diff stats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-04-18 21:41:05 +0100
committerJames Booth <boothj5@gmail.com>2014-04-18 21:41:05 +0100
commitdf345a2cfb7b2fd55826e833ba7e15c97d3a1c18 (patch)
treeee77da3849026e62bfcd2c42cb0a58123b85239a /Makefile.am
parentd3a23d42e4e6f049c6fdc47589438de772dcd9e4 (diff)
parent0c1092fd30984918e6c70ccdc3b6ba5f79b08f57 (diff)
downloadprofani-tty-df345a2cfb7b2fd55826e833ba7e15c97d3a1c18.tar.gz
Merge remote-tracking branch 'pasis/iss323'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 8e71f369..ecd6d598 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -79,8 +79,8 @@ tests_sources = \
 	tests/test_preferences.c \
 	tests/test_server_events.c \
 	tests/test_muc.c \
-    tests/test_cmd_roster.c \
-    tests/test_cmd_win.c \
+	tests/test_cmd_roster.c \
+	tests/test_cmd_win.c \
 	tests/testsuite.c
 
 main_source = src/main.c
@@ -93,6 +93,10 @@ otr3_sources = \
 otr4_sources = \
 	src/otr/otrlib.h src/otr/otrlibv4.c src/otr/otr.h src/otr/otr.c
 
+themes_sources = themes/*
+
+man_sources = docs/profanity.1
+
 if BUILD_OTR
 if BUILD_OTR3
 core_sources += $(otr3_sources)
@@ -106,6 +110,10 @@ endif
 
 bin_PROGRAMS = profanity
 profanity_SOURCES = $(core_sources) $(main_source)
+if THEMES_INSTALL
+profanity_themesdir = @THEMES_PATH@
+profanity_themes_DATA = $(themes_sources)
+endif
 if INCLUDE_GIT_VERSION
 BUILT_SOURCES = $(git_include)
 endif
@@ -115,9 +123,13 @@ check_PROGRAMS = tests/testsuite
 tests_testsuite_SOURCES = $(tests_sources)
 tests_testsuite_LDADD = -lcmocka
 
-man_MANS = docs/profanity.1
+man_MANS = $(man_sources)
+
+EXTRA_DIST = $(man_sources) $(themes_sources)
 
 if INCLUDE_GIT_VERSION
+EXTRA_DIST += .git/HEAD .git/index
+
 $(git_include).in: .git/HEAD .git/index
 	rm -f $@
 	echo "#ifndef PROF_GIT_BRANCH" >> $@