about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorJames Booth <boothj5@gmail.com>2014-01-12 02:15:16 +0000
committerJames Booth <boothj5@gmail.com>2014-01-12 02:15:16 +0000
commit264fc55aa22d0069d0031a97c56afd5f86df83c3 (patch)
tree15874d0a439c8823a53bc4d298b0aae1679829c7 /configure.ac
parent4e97c1e460d150b0cde6d8e35d8caf7bcf959a71 (diff)
downloadprofani-tty-264fc55aa22d0069d0031a97c56afd5f86df83c3.tar.gz
Added conditionals to makefile for otr support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4fb4deda..708432b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -130,12 +130,13 @@ elif test "x$with_xscreensaver" = x; then
         [AC_MSG_NOTICE([libX11 not found, falling back to profanity auto-away])])
 fi
 
+AM_CONDITIONAL([BUILD_OTR], [true])
 if test "x$enable_otr" = xyes; then
     AC_CHECK_LIB([otr], [main], [],
         [AC_MSG_ERROR([libotr is required for otr encryption support])])
 elif test "x$enable_otr" = x; then
     AC_CHECK_LIB([otr], [main], [],
-        [AC_MSG_NOTICE([libotr not found, otr entryption support no enabled])])
+        [AM_CONDITIONAL([BUILD_OTR], [false]) AC_MSG_NOTICE([libotr not found, otr entryption support not enabled])])
 fi
 
 ### cmocka is required only for tests, profanity shouldn't be linked with it