about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2022-02-18 10:09:29 +0100
committerMichael Vetter <jubalh@iodoru.org>2022-02-18 14:01:28 +0100
commit33106ecf9c6ebc50878476f734c9d4dddf103929 (patch)
tree8205f3efc04725431889f557c71b9986438811a1 /configure.ac
parent3f8720d70f6b4497ef2369a1e7e9b8fbebb4f5bd (diff)
downloadprofani-tty-33106ecf9c6ebc50878476f734c9d4dddf103929.tar.gz
build: remove otr3 support
All the distributions I checked have libotr 4.1.1 now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 8 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index f625c9c2..27715996 100644
--- a/configure.ac
+++ b/configure.ac
@@ -299,23 +299,17 @@ fi
 
 dnl feature: otr
 AM_CONDITIONAL([BUILD_OTR], [false])
-AM_CONDITIONAL([BUILD_OTR3], [false])
-AM_CONDITIONAL([BUILD_OTR4], [false])
 if test "x$enable_otr" != xno; then
     AM_CONDITIONAL([BUILD_OTR], [true])
+
     PKG_CHECK_MODULES([libotr], [libotr >= 4.0],
-        [AM_CONDITIONAL([BUILD_OTR4], [true])],
-        [AC_MSG_NOTICE([libotr >= 4.0 not found, checking for libotr-3.x...])
-         PKG_CHECK_MODULES([libotr], [libotr >= 3.0],
-            [AM_CONDITIONAL([BUILD_OTR3], [true])],
-            [AM_CONDITIONAL([BUILD_OTR], [false])])])
-
-    AM_COND_IF([BUILD_OTR],
-        [LIBS="$libotr_LIBS $LIBS" CFLAGS="$CFLAGS $libotr_CFLAGS"
-         AC_DEFINE([HAVE_LIBOTR], [1], [Have libotr])],
-        [AS_IF([test "x$enable_otr" = xyes],
-            [AC_MSG_ERROR([libotr is required for otr encryption support])],
-            [AC_MSG_NOTICE([libotr not found, otr encryption support not enabled])])])
+        [LIBS="$libotr_LIBS $LIBS" CFLAGS="$libotr_CFLAGS $cflags"],
+        [AM_CONDITIONAL([BUILD_OTR], [false])
+         AS_IF([test "x$enable_otr" = xyes],
+               [AC_MSG_ERROR([libotr >= 4.0 is required for OTR support])],
+               [AC_MSG_NOTICE([libotr >= 4.0 not found, OTR support not enabled])])])
+
+   AM_COND_IF([BUILD_OTR], [AC_DEFINE([HAVE_LIBOTR], [1], [Have libotr])])
 fi
 
 dnl feature: omemo