about summary refs log tree commit diff stats
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Fariello <paul@fariello.eu>2019-04-13 00:41:24 +0200
committerPaul Fariello <paul@fariello.eu>2019-04-13 00:41:24 +0200
commitb2dfdc7509416b7c1e8a753347753d04c4daff03 (patch)
treeba3782ca08e6739d8e8d5267a71594d8f32a609c /configure.ac
parentc00ab0351d72b23394435782fcd04da81bf0b8e1 (diff)
downloadprofani-tty-b2dfdc7509416b7c1e8a753347753d04c4daff03.tar.gz
Add libgcrypt minimum version in configure error log
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 097e13f7..4f6a6790 100644
--- a/configure.ac
+++ b/configure.ac
@@ -284,8 +284,8 @@ if test "x$enable_omemo" != xno; then
         [LIBS="-lgcrypt $LIBS"],
         [AM_CONDITIONAL([BUILD_OMEMO], [false])
          AS_IF([test "x$enable_omemo" = xyes],
-               [AC_MSG_ERROR([gcrypt is required for OMEMO support])],
-               [AC_MSG_NOTICE([gcrypt not found, OMEMO support not enabled])])])
+               [AC_MSG_ERROR([gcrypt >= 1.7.0 is required for OMEMO support])],
+               [AC_MSG_NOTICE([gcrypt >= 1.7.0 not found, OMEMO support not enabled])])])
 
    AM_COND_IF([BUILD_OMEMO], [AC_DEFINE([HAVE_OMEMO], [1], [Have OMEMO])])
 fi